Temporary Service Disruption

Incident Report for Purple Cow Internet

Resolved

As of 7:45 this morning our team was able to identify and resolve the issue. If you're still experiencing issues please attempt to reboot your modem, if the issue persists, please contact us at 902-800-2660.
Posted Mar 25, 2026 - 10:58 UTC

Identified

Our team was doing some upgrades in the data centre last night and ran into a technical issue in one area that caused a temporary disruption for several customers.

We are still working on it. Service has been restored for many of you, but there is still a segment without internet.

We will share another update once everything is fully restored.
Posted Mar 25, 2026 - 10:36 UTC