We're seeing customers service restored in these area's, If you're continuing to experience issues, please reboot your modem. If still not able to connect after rebooting, please text or call us at 902-800-2660.
Posted Apr 01, 2026 - 19:45 UTC
Monitoring
SS Page: Our Carrier has advised us that the issue impacting service for some of our customers is now resolved. If you're continuing to experience issues, please reboot your modem. If still not able to connect after rebooting, please text or call us at 902-800-2660.
Posted Apr 01, 2026 - 18:22 UTC
Identified
Update: Our team is still working closely with our Carrier to resolve this as soon as possible. We will continue to provide updates as they become available.
Posted Apr 01, 2026 - 17:43 UTC
Update
We are continuing to investigate the issues impacting customers in the Dartmouth area, and we are also aware that it is effecting some customers in Elmsdale, Enfield, Stewiacke - and we are working with our carrier to resolve this all for you as soon as possible.
Posted Apr 01, 2026 - 14:31 UTC
Investigating
We're aware of an issue affecting service for some customers in Dartmouth and are working closely with our Carrier to resolve as soon as possible. We will provides updates as they become available. Thanks for your patience!